Configuring IPv6 NAT6 for Guest WiFi Network on OpenWRT

First, add the guest WiFi network through the web interface or by modifying the configuration. The wireless interface added through the MTK management interface must be added to the bridge:

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

config globals 'globals'

option ula_prefix 'xxxx:xxxx:xxxx::/48'

config interface 'guest'

option proto 'static'

option ipaddr '10.0.100.1'

option netmask '255.255.255.0'

option device 'br-guest'

option ip6assign '64'

# Assigned prefix, i.e. xxxx:xxxx:xxxx:10::/64

option ip6hint 10

# Only assign the private network defined by ula_prefix. If pppoe can assign 60 or more, this option can be omitted to allocate the private network and wan_6 public network.

list ip6class local

config device

option type 'bridge'

option name 'br-guest'

list ports 'ra1'

list ports 'rax1'

If the interface is added through OpenWRT’s native wireless management, it should be added to the specified network without needing to be added to the bridge:

1

2

3

4

5

6

7

config wifi-iface 'wifinet3'

option device 'MT7986_1_1'

option mode 'ap'

option ssid '2.4G-guest'

option encryption 'psk-mixed'

option key 'www.haiyun.me'

option network 'guest'

DHCP configuration:

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

config dhcp 'guest'

option interface 'guest'

option start '150'

option limit '100'

option leasetime '12h'

option dhcpv4 'server'

list ra_flags 'none'

option dns_service '0'

option ra_default '2' # Force announce ipv6 route to clients

option ra 'server'

option ra_maxinterval '120'

option ra_ra_mininterval '60'

option ra_lifetime '1200'

option ra_useleasetime '1'

option preferred_lifetime '10m'

iptables configuration:

1

2

3

ip6tables -A INPUT -i br-guest -p icmpv6 -j ACCEPT

ip6tables -A FORWARD -i br-guest -o pppoe-wan -j ACCEPT

ip6tables -t nat -A POSTROUTING -s xxxx:xxxx:xxxx:10::/64 -o pppoe-wan -j MASQUERADE

When pppoe successfully obtains ipv6, add the default ipv6 route:

1

echo 'ip -6 rou add default via $LLREMOTE dev $IFNAME' >> /lib/netifd/ppp6-up

If dhcp is used, add hotplug to set the ipv6 default route:

1

2

3

4

#!/bin/bash

if [ $ACTION = "ifup" -a "$INTERFACE" = "wan6" ]; then

ip -6 rou add default via fe80::1 dev eth1

fi

Done

Welcome to follow the Kodi Chinese Community public account, search keywords in the public account to find related tutorials on Kodi and audio-visual storage devices. For group communication, please add the editor’s WeChat viqsoft XBMC/Kodi related Chinese version, enhanced version, modified version, and plugin download address summary: https://www.kodi.org.cn/download/

For more information, welcome to join the group for communication

WeChat group add viqsoft

Configuring IPv6 NAT6 for Guest WiFi Network on OpenWRT

QQ group

Configuring IPv6 NAT6 for Guest WiFi Network on OpenWRT

Douyin

Configuring IPv6 NAT6 for Guest WiFi Network on OpenWRT

Bilibili

Configuring IPv6 NAT6 for Guest WiFi Network on OpenWRT

Kodi Media Center is an award-winning free and open-source cross-platform media player and digital media entertainment center software for HTPC (Home Theater PC) that can run on Linux, OSX, Windows, and Android systems. It is an excellent free and open-source (GPL) media center software. Originally developed for Xbox, it was called XBMC (short for Xbox Media Center), which is the media center for the Xbox platform. For Xbox players, if XBMC is not installed, then playing Xbox loses at least half the fun. Due to the participation of developers from around the world, this software has far more features than ever before, and it can no longer be described as ‘just a simple player’. For this reason, after XBMC 14, it was renamed Kodi.

The graphical user interface of Kodi allows users to easily browse and watch videos, pictures, listen to broadcasts, and music from hard drives, CDs, local area networks, and the internet with a simple press of the remote control. The Kodi project is managed by the non-profit XBMC Foundation and developed by volunteers from around the world. Since its inception in 2003, over 500 software developers have contributed to Kodi, with 60 core developers. In addition, more than 200 translators are helping to expand its reach, supporting up to 72 languages.

Configuring IPv6 NAT6 for Guest WiFi Network on OpenWRT

Kodi (then called “Xbox Media Center”) was originally developed as a media center application for the first-generation Xbox game console (which is no longer supported), and now runs natively on Android, Linux, Mac OS X, iOS, and Windows operating systems, supporting mainstream processor architectures.

Feature Overview

Kodi can play almost all popular audio and video formats. Its design for network playback allows you to stream multimedia from anywhere on your home network or directly from the internet using various protocols. Use your media as-is: Kodi can play CDs and DVDs from disk or image files and supports reading from almost all popular compressed formats. Kodi scans all your media and creates a personalized library with complete cover images, descriptions, and fan art. It supports playlists and slideshow functions, weather forecast features, and various audio visualization effects. Once installed, your computer becomes a fully functional multimedia jukebox.

Kodi can provide various extended functions through plugins, developed both by the Kodi development team and third-party developers. With community support, Kodi’s online content plugins are continually growing, with the official plugin repository including YouTube, Hulu, Grooveshark, Pandora Radio, as well as skins (themes), and many unofficial plugin repositories maintained by third-party developers.

Language Support

Kodi supports a variety of different languages by default. Kodi has established a mechanism whereby if a certain language is not supported or updated, support can be added by registering for the Kodi Main Translation Project. Currently supported languages include Afrikaans, Basque, Brazilian Portuguese, Bulgarian, Catalan, Simplified Chinese, Traditional Chinese, Croatian, Czech, Danish, Dutch, English, American English, Esperanto, Finnish, French, German, Greek, Hebrew, Hungarian, Icelandic, Indonesian, Italian, Japanese, Korean, Maltese, Norwegian, Polish, Portuguese, Romanian, Russian, Serbian, Slovak, Slovenian, Spanish, Mexican Spanish, Swedish, Thai, Turkish, and Ukrainian.

Hardware Requirements

Kodi requires a 3D GPU graphics hardware controller to support rendering. Such 3D GPU chips are now standard in computers, and many set-top boxes are equipped with them. Kodi runs well on systems compatible with OpenGL 1.3 (with GLSL support), OpenGL ES 2.0, or Direct3D (DirectX) 9.0 on IA-32/x86, x86-64, or ARM CPU-based systems.

When decoding 1080p full HD video software, a dual-core 2GHz or stronger CPU is required to ensure smooth playback without frame drops or stuttering. Kodi can offload most video decoding processing to GPUs and VPUs that support the following video hardware decoding interfaces: Android StageFright and MediaCodec API, Intel’s VAAPI, Nvidia’s VDPAU, AMD’s XvBA, Microsoft’s DXVA, Apple’s VDADecoder/VideoToolBox, or OpenMAX. Thanks to this type of hardware video decoding, Kodi can run well on inexpensive, low-power systems with modern GPUs and VPUs.

Kodi Official Release Versions

Fully functional Kodi can run on multiple platforms. The Kodi development team strives to maintain feature consistency across versions for different platforms, including those low-power devices.

Kodibuntu

KodiBuntu (formerly XBMCbuntu) is a free Linux distribution based on Ubuntu with Kodi pre-installed. It provides a complete media center software package for all IA-32/x86 architecture personal computers. KodiBuntu is based on Lubuntu rather than the desktop version of Ubuntu.

Android

The Android version of Kodi was first announced on June 13, 2012, and the source code was released. It is a complete port for Google’s Android operating system. This port does not use Java at all but fully ports Kodi’s C++ and C source code and all dependencies through the Android NDK (Native Development Kit for Android) for multiple processor architectures (such as ARM, MIPS, and x86). Kodi.APK is a native Android application.

iOS

The iOS version of Kodi was first publicly released on January 20, 2011, and is a complete port for Apple’s iOS operating system. It supports hardware decoding of 720p and 1080p H.264 video and is compatible with various Apple mobile devices using Apple A4 or higher processors. It requires jailbreaking the iOS operating system.

Linux

The Linux version of Kodi is primarily developed for Ubuntu. There are also some third-party installation packages for other Linux distributions. Additionally, Kodi can be compiled from source on any Linux distribution with the necessary libraries installed.

Mac

The Mac version of Kodi runs on Intel processor-based Mac OS X systems and supports H.264 hardware decoding.

Windows

The Windows version of Kodi requires Windows Vista or higher. It is a 32-bit application and can also run on 64-bit Windows and hardware systems. Since it is not optimized for 64-bit systems, running it on 64-bit Windows does not enhance performance.

Source: Self-proclaimed Kodi official website

Follow me to master cutting-edge technology and easily cope with future challenges!

Students interested in audio-visual technology can follow the following public accounts:

Kodi: Chinese user community of soft food hard obsession

Speed limit sixty: Automotive electric vehicle audio-visual related tools sharing

Memory technology: Focus on technology, store the future

Dakai audio-visual: Dakai.TV

Memory leak: Safety first, customer rescue

Today’s sharing ends here. If you like it, please give a free 👍 below.

Leave a Comment

×